const regex = /^(?=.*?[A-Z0-9]$)[A-Z][\w-]*$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*?[A-Z0-9]$)[A-Z][\\w-]*$', 'igm')
const str = `a123
a
a_`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);