$re = '/^(?=.*?[A-Z0-9]$)[A-Z][\w-]*$/im';
$str = 'a123
a
a_';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;