use strict;
my $str = 'a123
a
a_';
my $regex = qr/^(?=.*?[A-Z0-9]$)[A-Z][\w-]*$/imp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";