#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^(?=.*?[A-Z0-9]$)[A-Z][\w-]*$"
Local $sString = "a123" & @CRLF & _
"a" & @CRLF & _
"a_"
Local $sSubst = "."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)