const regex = /(?s)<div class="some-class">(.*?)<\/div>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<div class="some-class">(.*?)<\\\/div>', '')
const str = `<div class="foobar">
<div class="myclass">some stuff, and
<div class="some-class">
some other stuff
</div>
</div>
</div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}