$re = '/(?s)<div class="some-class">(.*?)<\/div>/';
$str = '<div class="foobar">
<div class="myclass">some stuff, and
<div class="some-class">
some other stuff
</div>
</div>
</div>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);