re = /(?s)<div class="some-class">(.*?)<\/div>/
str = '<div class="foobar">
<div class="myclass">some stuff, and
<div class="some-class">
some other stuff
</div>
</div>
</div>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end