const regex = /^[^\S\r\n]{19,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\S\\r\\n]{19,}', 'gm')
const str = `<div>
<div>
<pre>
<code>
<h1>Hello world</h1>
</code>
</pre>
</div>
</div>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);