import re
regex = re.compile(r"^[^\S\r\n]{19,}", flags=re.MULTILINE)
test_str = ("<div>\n"
" <div>\n"
" <pre>\n"
" <code>\n"
" <h1>Hello world</h1>\n"
" </code>\n"
" </pre>\n"
" </div>\n"
" </div>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)