re = /^[^\S\r\n]{19,}/m
str = '<div>
<div>
<pre>
<code>
<h1>Hello world</h1>
</code>
</pre>
</div>
</div>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result