#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\||\/]{2,})"
Local $sString = "levoca" & @CRLF & _
"levo|||dss" & @CRLF & _
"levoc\\a" & @CRLF & _
"" & @CRLF & _
"password"||""=="" & @CRLF & _
"" & @CRLF & _
"gs5bw"||1==1//" & @CRLF & _
"" & @CRLF & _
"(\|{2,}|\/{2,})" & @CRLF & _
"" & @CRLF & _
"[\|||||||\/]{2,}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")