# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\??(([^\sğ]) ?\w*)(?<![dD]e.il)\s?(mi\s?\??)/$1?/gm;t' <<< "---MATCH---
Ahmet mi?
Ahmet mi ?
Beğendiniz mi?
Değil mi? Michael mi?...
Hadi bakalım. Ahmet mi?
Hadi bakalım, Ahmet mi?
Hadi bakalım. Ahmet mi ?
Hadi bakalım. Olabilir mi?
Michael mi? Neden bana söylemediniz?
---NON-MATCH---
Hadi bakalım. Gelecek olan Ahmet mi?
Bunu beğendiniz mi?
Değil mi?
Olabilir değil mi?
Değil mi ?
Ahmet.mi?
mi?
Mi?
Minik?
Kimi?"