import Foundation
let pattern = #"\??(([^\sğ]) ?\w*)(?<![dD]e.il)\s?(mi\s?\??)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
---MATCH---
Ahmet mi?
Ahmet mi ?
Beğendiniz mi?
Değil mi? Michael mi?...
Hadi bakalım. Ahmet mi?
Hadi bakalım, Ahmet mi?
Hadi bakalım. Ahmet mi ?
Hadi bakalım. Olabilir mi?
Michael mi? Neden bana söylemediniz?
---NON-MATCH---
Hadi bakalım. Gelecek olan Ahmet mi?
Bunu beğendiniz mi?
Değil mi?
Olabilir değil mi?
Değil mi ?
Ahmet.mi?
mi?
Mi?
Minik?
Kimi?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1?"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)