import re
regex = re.compile(r"\??(([^\sğ]) ?\w*)(?<![dD]e.il)\s?(mi\s?\??)", flags=re.MULTILINE)
test_str = ("---MATCH---\n"
"Ahmet mi?\n"
"Ahmet mi ?\n"
"Beğendiniz mi?\n"
"Değil mi? Michael mi?...\n"
"Hadi bakalım. Ahmet mi?\n"
"Hadi bakalım, Ahmet mi?\n"
"Hadi bakalım. Ahmet mi ?\n"
"Hadi bakalım. Olabilir mi?\n"
"Michael mi? Neden bana söylemediniz?\n\n"
"---NON-MATCH---\n"
"Hadi bakalım. Gelecek olan Ahmet mi?\n"
"Bunu beğendiniz mi?\n"
"Değil mi?\n"
"Olabilir değil mi?\n"
"Değil mi ?\n"
"Ahmet.mi?\n"
"mi?\n"
"Mi?\n"
"Minik?\n"
"Kimi?")
subst = "$1?"
result = regex.sub(subst, test_str)
if result:
print(result)