use strict;
my $str = '---MATCH---
Ahmet mi?
Ahmet mi ?
Beğendiniz mi?
Değil mi? Michael mi?...
Hadi bakalım. Ahmet mi?
Hadi bakalım, Ahmet mi?
Hadi bakalım. Ahmet mi ?
Hadi bakalım. Olabilir mi?
Michael mi? Neden bana söylemediniz?
---NON-MATCH---
Hadi bakalım. Gelecek olan Ahmet mi?
Bunu beğendiniz mi?
Değil mi?
Olabilir değil mi?
Değil mi ?
Ahmet.mi?
mi?
Mi?
Minik?
Kimi?';
my $regex = qr/\??(([^\sğ]) ?\w*)(?<![dD]e.il)\s?(mi\s?\??)/mp;
my $subst = '$1?';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";