import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\??(([^\\sğ]) ?\\w*)(?<![dD]e.il)\\s?(mi\\s?\\??)";
final String string = "---MATCH---\n"
+ "Ahmet mi?\n"
+ "Ahmet mi ?\n"
+ "Beğendiniz mi?\n"
+ "Değil mi? Michael mi?...\n"
+ "Hadi bakalım. Ahmet mi?\n"
+ "Hadi bakalım, Ahmet mi?\n"
+ "Hadi bakalım. Ahmet mi ?\n"
+ "Hadi bakalım. Olabilir mi?\n"
+ "Michael mi? Neden bana söylemediniz?\n\n"
+ "---NON-MATCH---\n"
+ "Hadi bakalım. Gelecek olan Ahmet mi?\n"
+ "Bunu beğendiniz mi?\n"
+ "Değil mi?\n"
+ "Olabilir değil mi?\n"
+ "Değil mi ?\n"
+ "Ahmet.mi?\n"
+ "mi?\n"
+ "Mi?\n"
+ "Minik?\n"
+ "Kimi?";
final String subst = "$1?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}