const regex = /layout\s*=(?!=)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('layout\\s*=(?!=)\\s*', 'gm')
const str = `change layout = ""`;
const subst = `layout=`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);