use strict;
my $str = 'change layout = ""';
my $regex = qr/layout\s*=(?!=)\s*/mp;
my $subst = 'layout=';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";