import Foundation
let pattern = #"layout\s*=(?!=)\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"change layout = """#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"layout="#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)