$re = '/"([^"\\\\]*(?:\\\\.[^"\\\\]*)*)"|\w+|\'([^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\'/';
$str = '"The Doors" "Peace Frog" "Down The Road" Bootleg "lol noth\\"ing here" something rofl lol "wtf is going on" \'nope noe noe\' "\'\'\'" "something\'s fishy here..." \'are we "sure that this will work?"\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);