// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""([^"\\]*(?:\\.[^"\\]*)*)"|\w+|'([^'\\]*(?:\\.[^'\\]*)*)'"#).unwrap();
let string = "\"The Doors\" \"Peace Frog\" \"Down The Road\" Bootleg \"lol noth\\\"ing here\" something rofl lol \"wtf is going on\" 'nope noe noe' \"'''\" \"something's fishy here...\" 'are we \"sure that this will work?\"'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}