#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:@|(?:(?:(?:https?://)?t(?:elegram)?)\.me\/))(\w{4,})$"
Local $sString = "add @amir_720" & @CRLF & _
"add https://t.me/amir_720" & @CRLF & _
"add https://telegram.me/amir_720" & @CRLF & _
"add http://t.me/amir_720" & @CRLF & _
"" & @CRLF & _
"add https://t.me/itweeter"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")