$re = '/(?:@|(?:(?:(?:https?://)?t(?:elegram)?)\.me\/))(\w{4,})$/m';
$str = 'add @amir_720
add https://t.me/amir_720
add https://telegram.me/amir_720
add http://t.me/amir_720
add https://t.me/itweeter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);