using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:@|(?:(?:(?:https?://)?t(?:elegram)?)\.me\/))(\w{4,})$";
string input = @"add @amir_720
add https://t.me/amir_720
add https://telegram.me/amir_720
add http://t.me/amir_720
add https://t.me/itweeter";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}