package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:@|(?:(?:(?:https?://)?t(?:elegram)?)\.me\/))(\w{4,})$`)
var str = `add @amir_720
add https://t.me/amir_720
add https://telegram.me/amir_720
add http://t.me/amir_720
add https://t.me/itweeter`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}