// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:@|(?:(?:(?:https?://)?t(?:elegram)?)\.me\/))(\w{4,})$").unwrap();
let string = "add @amir_720
add https://t.me/amir_720
add https://telegram.me/amir_720
add http://t.me/amir_720
add https://t.me/itweeter";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}