const regex = /(?<IntKey>[^\s<>{}]+)\s*<(?<IntValue>\d+)>|
(?<TrueKey>[^\s<>{}]+)\s*<yes>|
(?<FalseKey>[^\s<>{}]+)\s*<no>|
(?<StrKey>[^\s<>{}]+)\s*<(?<StrValue>.*?)>|
(?<ObjectBegin>[^\s<>{}]+)\s*\{|
(?<ObjectEnd>\})|
(?<KeyOnly>[^\s<>{}]+)|
(?<Invalid>\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<IntKey>[^\\s<>{}]+)\\s*<(?<IntValue>\\d+)>|
(?<TrueKey>[^\\s<>{}]+)\\s*<yes>|
(?<FalseKey>[^\\s<>{}]+)\\s*<no>|
(?<StrKey>[^\\s<>{}]+)\\s*<(?<StrValue>.*?)>|
(?<ObjectBegin>[^\\s<>{}]+)\\s*\\{|
(?<ObjectEnd>\\})|
(?<KeyOnly>[^\\s<>{}]+)|
(?<Invalid>\\S+)', 'gm')
const str = `servername {
store {
servers {
* {
value<>
port<>
folder<C:\\windows> monitor<yes>
args<-T -H>
xrg<store>
wysargs<-t -g -b>
accept_any<yes>
pdu_length<23622>
}
test1 {
name<test1>
port<123>
root<c:\\test>
monitor<yes>
}
test2 {
name<test2>
port<124>
root<c:\\test>
monitor<yes>
}
test3 {
name<test3>
port<125>
root<c:\\test>
monitor<yes>
}
}
senders
timeout<30>
}
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}