use strict;
my $str = 'servername {
store {
servers {
* {
value<>
port<>
folder<C:\\windows> monitor<yes>
args<-T -H>
xrg<store>
wysargs<-t -g -b>
accept_any<yes>
pdu_length<23622>
}
test1 {
name<test1>
port<123>
root<c:\\test>
monitor<yes>
}
test2 {
name<test2>
port<124>
root<c:\\test>
monitor<yes>
}
test3 {
name<test3>
port<125>
root<c:\\test>
monitor<yes>
}
}
senders
timeout<30>
}
}
';
my $regex = qr/(?<IntKey>[^\s<>{}]+)\s*<(?<IntValue>\d+)>|
(?<TrueKey>[^\s<>{}]+)\s*<yes>|
(?<FalseKey>[^\s<>{}]+)\s*<no>|
(?<StrKey>[^\s<>{}]+)\s*<(?<StrValue>.*?)>|
(?<ObjectBegin>[^\s<>{}]+)\s*\{|
(?<ObjectEnd>\})|
(?<KeyOnly>[^\s<>{}]+)|
(?<Invalid>\S+)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}