// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?<IntKey>[^\s<>{}]+)\s*<(?<IntValue>\d+)>|
(?<TrueKey>[^\s<>{}]+)\s*<yes>|
(?<FalseKey>[^\s<>{}]+)\s*<no>|
(?<StrKey>[^\s<>{}]+)\s*<(?<StrValue>.*?)>|
(?<ObjectBegin>[^\s<>{}]+)\s*\{|
(?<ObjectEnd>\})|
(?<KeyOnly>[^\s<>{}]+)|
(?<Invalid>\S+)").unwrap();
let string = "servername {
store {
servers {
* {
value<>
port<>
folder<C:\\windows> monitor<yes>
args<-T -H>
xrg<store>
wysargs<-t -g -b>
accept_any<yes>
pdu_length<23622>
}
test1 {
name<test1>
port<123>
root<c:\\test>
monitor<yes>
}
test2 {
name<test2>
port<124>
root<c:\\test>
monitor<yes>
}
test3 {
name<test3>
port<125>
root<c:\\test>
monitor<yes>
}
}
senders
timeout<30>
}
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}