# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?<IntKey>[^\s<>{}]+)\s*<(?<IntValue>\d+)>|
(?<TrueKey>[^\s<>{}]+)\s*<yes>|
(?<FalseKey>[^\s<>{}]+)\s*<no>|
(?<StrKey>[^\s<>{}]+)\s*<(?<StrValue>.*?)>|
(?<ObjectBegin>[^\s<>{}]+)\s*\{|
(?<ObjectEnd>\})|
(?<KeyOnly>[^\s<>{}]+)|
(?<Invalid>\S+)
"""
test_str = ("servername {\n"
" store { \n"
" servers {\n"
" * {\n"
" value<>\n"
" port<>\n"
" folder<C:\\windows> monitor<yes>\n"
" args<-T -H>\n"
" xrg<store>\n"
" wysargs<-t -g -b>\n"
" accept_any<yes>\n"
" pdu_length<23622>\n"
" }\n"
" test1 {\n"
" name<test1>\n"
" port<123>\n"
" root<c:\\test>\n"
" monitor<yes>\n"
" }\n"
" test2 {\n"
" name<test2>\n"
" port<124>\n"
" root<c:\\test>\n"
" monitor<yes>\n"
" }\n"
" test3 {\n"
" name<test3>\n"
" port<125>\n"
" root<c:\\test>\n"
" monitor<yes>\n"
" }\n"
" }\n"
" senders\n"
" timeout<30>\n"
" }\n"
"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.