package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
(?P<user>.*?)@
(?P<host>.*?):
(?:(?P<port>.*?)/)?
(?P<path>.*?/.*?)
$`)
var str = `git@github.com:james/example
git@github.com:007/example
git@github.com:22/james/example
git@github.com:22/007/example`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}