import re
regex = re.compile(r"""
^
(?P<user>.*?)@
(?P<host>.*?):
(?:(?P<port>.*?)/)?
(?P<path>.*?/.*?)
$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("git@github.com:james/example\n"
"git@github.com:007/example\n"
"git@github.com:22/james/example\n"
"git@github.com:22/007/example")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")