$re = '~^
(?P<user>.*?)@
(?P<host>.*?):
(?:(?P<port>.*?)/)?
(?P<path>.*?/.*?)
$~mx';
$str = 'git@github.com:james/example
git@github.com:007/example
git@github.com:22/james/example
git@github.com:22/007/example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);