import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?P<user>.*?)@\n"
+ "(?P<host>.*?):\n"
+ "(?:(?P<port>.*?)/)?\n"
+ "(?P<path>.*?/.*?)\n"
+ "$";
final String string = "git@github.com:james/example\n"
+ "git@github.com:007/example\n"
+ "git@github.com:22/james/example\n"
+ "git@github.com:22/007/example";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}