re = /^
(?P<user>.*?)@
(?P<host>.*?):
(?:(?P<port>.*?)\/)?
(?P<path>.*?\/.*?)
$/mx
str = 'git@github.com:james/example
git@github.com:007/example
git@github.com:22/james/example
git@github.com:22/007/example'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end