#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:\G(?!\A)|^(?=.*WORD1)(?=.*WORD2)).*?\n\K(?-s).*WORD2"
Local $sString = "Report Name" & @CRLF & _
"Report Date" & @CRLF & _
"Blah blah blah" & @CRLF & _
"Blah: WORD1" & @CRLF & _
"Blah blah" & @CRLF & _
"blah blah: WORD2" & @CRLF & _
"blah blah" & @CRLF & _
"Report Name" & @CRLF & _
"Report Date" & @CRLF & _
"Blah blah blah" & @CRLF & _
"Blah: WORD1" & @CRLF & _
"Blah blah" & @CRLF & _
"blah blah: WORD2" & @CRLF & _
"blah blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")