re = /(?s)(?:\G(?!\A)|^(?=.*WORD1)(?=.*WORD2)).*?\n\K(?-s).*WORD2/
str = 'Report Name
Report Date
Blah blah blah
Blah: WORD1
Blah blah
blah blah: WORD2
blah blah
Report Name
Report Date
Blah blah blah
Blah: WORD1
Blah blah
blah blah: WORD2
blah blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end