const regex = /(?s)(?:\G(?!\A)|^(?=.*WORD1)(?=.*WORD2)).*?\n\K(?-s).*WORD2/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?:\\G(?!\\A)|^(?=.*WORD1)(?=.*WORD2)).*?\\n\\K(?-s).*WORD2', 'g')
const str = `Report Name
Report Date
Blah blah blah
Blah: WORD1
Blah blah
blah blah: WORD2
blah blah
Report Name
Report Date
Blah blah blah
Blah: WORD1
Blah blah
blah blah: WORD2
blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}