import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?:\\G(?!\\A)|^(?=.*WORD1)(?=.*WORD2)).*?\\n\\K(?-s).*WORD2";
final String string = "Report Name\n"
+ "Report Date\n"
+ "Blah blah blah\n"
+ "Blah: WORD1\n"
+ "Blah blah\n"
+ "blah blah: WORD2\n"
+ "blah blah\n"
+ "Report Name\n"
+ "Report Date\n"
+ "Blah blah blah\n"
+ "Blah: WORD1\n"
+ "Blah blah\n"
+ "blah blah: WORD2\n"
+ "blah blah";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}