const regex = /(?<=\href=")(.*?)(?=\/css)(?<![A-z0-9])/sm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\href=")(.*?)(?=\\\/css)(?<![A-z0-9])', 'sm')
const str = `<link rel="stylesheet" type="text/css" href="/css/clients.insights.de6509e7.css">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}