re = /(?<=\href=")(.*?)(?=\/css)(?<![A-z0-9])/m
str = '<link rel="stylesheet" type="text/css" href="/css/clients.insights.de6509e7.css">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end