$re = '/(?<=\href=")(.*?)(?=\/css)(?<![A-z0-9])/sm';
$str = '<link rel="stylesheet" type="text/css" href="/css/clients.insights.de6509e7.css">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);