import re
regex = re.compile(r"(?<=\href=\")(.*?)(?=\/css)(?<![A-z0-9])", flags=re.DOTALL | re.MULTILINE)
test_str = "<link rel=\"stylesheet\" type=\"text/css\" href=\"/css/clients.insights.de6509e7.css\">"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")