#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^TITLE:[^\|]*\|(.*)|NAVIGATE:([^\|]*)\|([^\||\n]*)(\|(.*))?|MOVE:([0-9]+(\.[0-9]+)?)\|(\d*)\|(\d*)\|(\d*)"
Local $sString = "title:ssss" & @CRLF & _
"MOVE:12.3|456|456|7486" & @CRLF & _
"NAVIGATE:IE|http://www.google.fr|TiTRE" & @CRLF & _
"NAVIGATE:IE|http://www.google.fr" & @CRLF & _
"MOVE:12.3|456|456|7486" & @CRLF & _
"TITLE:ddfdfs|sdsqdqs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")