using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^TITLE:[^\|]*\|(.*)|NAVIGATE:([^\|]*)\|([^\||\n]*)(\|(.*))?|MOVE:([0-9]+(\.[0-9]+)?)\|(\d*)\|(\d*)\|(\d*)";
string input = @"title:ssss
MOVE:12.3|456|456|7486
NAVIGATE:IE|http://www.google.fr|TiTRE
NAVIGATE:IE|http://www.google.fr
MOVE:12.3|456|456|7486
TITLE:ddfdfs|sdsqdqs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}