import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^TITLE:[^\\|]*\\|(.*)|NAVIGATE:([^\\|]*)\\|([^\\||\\n]*)(\\|(.*))?|MOVE:([0-9]+(\\.[0-9]+)?)\\|(\\d*)\\|(\\d*)\\|(\\d*)";
final String string = "title:ssss\n"
+ "MOVE:12.3|456|456|7486\n"
+ "NAVIGATE:IE|http://www.google.fr|TiTRE\n"
+ "NAVIGATE:IE|http://www.google.fr\n"
+ "MOVE:12.3|456|456|7486\n"
+ "TITLE:ddfdfs|sdsqdqs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}