use strict;
my $str = 'title:ssss
MOVE:12.3|456|456|7486
NAVIGATE:IE|http://www.google.fr|TiTRE
NAVIGATE:IE|http://www.google.fr
MOVE:12.3|456|456|7486
TITLE:ddfdfs|sdsqdqs';
my $regex = qr/^TITLE:[^\|]*\|(.*)|NAVIGATE:([^\|]*)\|([^\||\n]*)(\|(.*))?|MOVE:([0-9]+(\.[0-9]+)?)\|(\d*)\|(\d*)\|(\d*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}