$re = '/^TITLE:[^\|]*\|(.*)|NAVIGATE:([^\|]*)\|([^\||\n]*)(\|(.*))?|MOVE:([0-9]+(\.[0-9]+)?)\|(\d*)\|(\d*)\|(\d*)/m';
$str = 'title:ssss
MOVE:12.3|456|456|7486
NAVIGATE:IE|http://www.google.fr|TiTRE
NAVIGATE:IE|http://www.google.fr
MOVE:12.3|456|456|7486
TITLE:ddfdfs|sdsqdqs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);