#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)PAccountRegistered1"\s*:\s*"([0-9])""
Local $sString = "{"response":"success", "body":{"vendor_fullname":"Avaya Inc.","P35":"","PServer1":"10.2.0.100","PAccountRegistered1":"1","PBackupServer1":"10.2.0.50","PAccountBackupRegistered1":"0"}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")