use strict;
my $str = '{"response":"success", "body":{"vendor_fullname":"Avaya Inc.","P35":"","PServer1":"10.2.0.100","PAccountRegistered1":"1","PBackupServer1":"10.2.0.50","PAccountBackupRegistered1":"0"}}';
my $regex = qr/PAccountRegistered1"\s*:\s*"([0-9])"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}